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Preface

This User Guide is been implemented by Boot & Work, S.L. working
under the name Industrial Shields.

Purpose of the manual

The information contained in this manual can be used as a reference to operating, to
functions, and to the technical data of the signal modules, power supply modules and
interface modules.

Intended Audience
This User Guide is intended for the following audience:

e Persons in charge of introducing automation devices.
e Persons who design automation systems.

e Persons who install or connect automation devices.

e Persons who manage working automation installation.
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4@ Warnings:

e Unused pins should not be connected. Ignoring the directive may damage the
controller.

e Improper use of this product may severely damage the controller.

e Referto the controller’s User Guide regarding wiring considerations.

e Before using this product, it is the responsibility of the user to read the product’s User
Guide and all accompanying documentation.



Application Considerations and Warranty

Read and Understand this Manual

Please read and understand this manual before using the product. Please consult your
comments or questions to Industrial Shields before using the product.

Application Consideration

THE PRODUCTS CONTAINED IN THIS DOCUMENT ARE NOT SAFETY RATED.
THEY SHOULD NOT BE RELIED UPON AS A SAFETY COMPONENT OR
PROTECTIVE DEVICE FOR ENSURING SAFETY OF PERSONS, AS THEY ARE
NOT RATED OR DESSIGNED FOR SUCH PURPOSES.

Please know and observe all prohibitions of use applicable to the products.

FOR AN APPLICATION INVOLVING SERIOUS RISK TO LIFE OR PROPERTY
WITHOUT ENSURING THAT THE SYSTEM AS A WHOLE HAS BEEN DESSIGNED
TO ADDRESS THE RISKS, NEVER USE THE INDUSTRIAL SHIELDS PRODUCTS.

NEVER USE THE INDUSTRIAL SHIELDS PRODUCTS BEFORE THEY ARE
PROPERLY RATED AND INSTALLED FOR THE INTENDED USE WITHIN THE
OVERALL EQUIPMENT OR SYSTEM.

Industrial Shields shall not be responsible for conformity with any codes, regulations or
standards that apply to the combination of products in the customer’s application or use
of the product.

The following are some examples of applications for which particular attention must be
given. This is not intended to be an exhaustive list of all possible uses of the products,
nor is it intended to imply that the uses may be suitable for the products:

e Systems, machines, and equipment that could present a risk to life or property.

¢ Nuclear energy control systems, combustion systems, railroad systems,
aviation systems, medical equipment, amusement machines, vehicles, safety
equipment, and installation subject to separate industry or government
regulations.

e Outdoor use, uses involving potential chemical contamination or electrical
interference, or conditions or uses not described in this document.

At the customer’s request, INDUSTRIAL SHIELDS will provide applicable third party
certification documents identifying ratings and limitations of use that apply to the
products. This information by itself is not sufficient for a complete determination of the
suitability of the products in combination with the system, machine, end product, or
other application or use.



Disclaimers

Weights and Dimensions

Dimensions and weights are nominal and they are not used for manufacturing
purposes, even when tolerances are shown.

Performance Data

The performance data given in this manual is provided as a guide for the user in
determining suitability and does not constitute a warranty. It may represent the result of
INDUSTRIAL SHIELDS’s test conditions, and the users most correlate it to actual
application requirements. Actual performance is subject to the INDUSTRIAL SHIELDS
Warranty and Limitations of Liability.

Change in Specifications

Product specifications and accessories may be changed at any time based on
improvements and other reasons.

It is our practice to change model numbers when features are changed, or published
ratings or when significant construction changes are made. However, some
specifications of the products may be changed without any notice. When in doubt,
special numbers may be assigned to fix or stablish key specifications for your
application on your request. Please consult with your INDUSTRIAL SHIELDS
representative at any time to confirm actual specifications of purchased products.

Errors and Omissions

The information in this document has been carefully checked and is believed to be
accurate; however, no responsibility is assumed for clerical, typographical, or
proofreading errors, or omissions.



Warranty and Limitations of Liability

Warranty

Industrial Shields’s exclusive warranty is that the products are free from defects in
materials and workmanship for a period of one year (or other period if specified) from
date of sale by Industrial Shields.

INDUSTRIAL SHIELDS MAKES NO REPRESENTATION OR WARRANTY,
EXPRESSED OR IMPLIED, REGARDING MERCHANABILITY, NON-
INFRINGEMENT, OR FITNESS FOR PARTICULAR PURPOSE OF THE PRODUCTS.
ANY BUYER OR USER ACKNOWLEDGES THAT THE BUYER OR USER ALONE
HAS DETERMINED THAT THE PRODUCTS WILL SUITABLY MEET THE
REQUIREMENTS OF THEIR INTENDED USE. INDUSTRIAL SHIELDS DISCLAIMS
ALL OTHER WARRANTIES, EXPRESS OR IMPLIED

Limitations of Liability

INDUSTRIAL SHIELDS SHALL NOT BE RESPONSIBLE FOR SPECIAL, INDIRECT,
OR CONSEQUENTIAL DAMAGES, LOSS OF PROFITS OR COMERCIAL LOSS IN
ANY WAY CONNECTED WITH THE PRODUCTS, WHETHER SUCH CLAIM IS
BASED ON CONTRACT, WARRANTY, NEGLIGENCE, OR STRICT LIABILITY.

IN NO EVENT SHALL INDUSTRIAL SHIELDS BE RESPONISBLE FOR WARRANTY,
REPAIR OR OTHER CLAIMS REGARDING THE PRODUCTS UNLESS INDUSTRIAL
SHIELDS’S ANALYSIS CONFIRMS THAT THE PRODUCTS WERE PROPERLY
HANDLED, STORED, INSTALLED, AND MAINTAINED AND NOT SUBJECT TO
CONTAMINATION, ABUSE, MISUSE, OR INAPPROPIATE MODIFICATION OR
REPAIR.
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INDUSTRIAL SHIELDS

1 General Description Wi-Fi & Bluetooth CONTROLLER

1.1 Zone - Nomenclature

The nomenclature shown in this point will be used in the whole User Guide, so it is
important to understand this nomenclature.

The nomenclature to differentiate the zones is based on the Alphabet, being A the
shield from below and B the shield from above.
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-man.; AZONE

e The inputs in the zone B are named 10.X, being X any number suitable in the
Shield. Outputs are named as Q0.X and Analog Outputs are named as A0.X

1.2  Zone Distribution



ZONE A ~ ZONEB

A A
Communication Relay Shield
1.3 A Zone Features

Shield A Zone

(1x) Ethernet

(1x) USB

(Ix) 12C

(3x) TTL

(1x) RS-232

Communication | (1x) HALF/FULL Duplex RS-485

Shield (1x) SPI external Port

(1x) RTC

(1x) uSD Socket
(1x) WiFi & BLE

1.4  Mechanical dimension




1.5 General Features

CONECTABLE PLC ARDUINO 24Vcc M-DUINO

WiFi & BLE Controller General Spec.

MODEL TYPE
Fuse protection (2.5A)
Input Voltage 12 to 24Vdc Polarity protection
| max. 1.5A
Size 101x119.5x70.1 101x119.5x119.3
Clock Speed 16MHz
Flash Memory 256KB of which 8KB used by bootloader
SRAM 8KB
EEPROM 4KB
I2C — Ethernet Port — USB — WiFi &BLE — RS485 — RS232 -- SPI Max232-Max485-W5500-ESP32

Communications

— (1x) Rx, Tx (Arduino pins)

Cannot be working in a final

USB consideration!

Only meant for uploading or debugging, not always connected

as a serial in a project!

application

An/Dig Input 10bit
(0-10Vcce)

0 to 10V
Input Impedance: 39K
Separated PCB ground

Digital Isolated Input (24vcc)

7 to 24Vdc
I min: 2to 12 mA
Galvanic Isolation

. 7 to 24Vdc
* Interrupt isolated Input HS I min: 2 to 12 mA
(24Vcc) Galvanic Isolation
. 0 to 10Vvdc
Analog Output 8bit | max: 20 mA
(0-10Vcce) Separated PCB ground
5 to 24Vdc
I max: 70 mA

Digital Isolated Output (24Vcc)

Galvanic Isolation
Diode Protected for Relay

Imax 24Vdc: 410 mA

PWM Isolated Output 8bit
(24Vvcc)

5 to 24Vdc
I max: 70 mA
Galvanic Isolation
Diode Protected for Relay

12C - 127 elements - Serial Port RS232/RS485/WiFi/BLE

Expandability

* By using this type of signal can no longer use Digital sighal (24Vdc)




2 Technical Specifications:

2.1  General Specifications:

Item

M-DUINO B ZONE

Power supply

voltage DC power supply

12 to 24Vvdc

Operating

voltage range DC power supply

11.4 to 25.4Vdc

Power
consumption DC power supply 30VAC max.
Power supply 24vdc
External voltage
power supply
Power supply 700Ma

output capacity

Insulation resistance

20MQ min.at 500Vdc between the AC terminals and the protective earth terminal.

Dielectric strength

2.300 VAC at 50/60 Hz for one minute with a leakage current of 10mA max. Between all the
external AC terminals and the protective ground terminal.

Shock resistance

80m/s? in the X, Y and Z direction 2 times each.

Ambient temperature (operating)

0° to 45°C

Ambient humidity (operating)

10% to 90% (no condensation)

Ambient environment (operating)

With no corrosive gas

Ambient temperature (storage) -20° to 60°C
Power supply holding time 2ms min.
Weight 4659 max.

2.2 Performance Specification:

Arduino Board

ARDUINO MEGA 2560

Control method

Stored program method

1/0 control method

Combination of the cyclic scan and immediate refresh processing methods.

Programming language

Arduino IDE. Based on wiring (Wiring is an Open Source electronics platform composed of a
programming language. “similar to the C”. http://arduino.cc/en/Tutorial/HomePage

Microcontroller

ATmega2560

Flash Memory

256KB of which 8KB are used by the bootloader

Program capacity (SRAM) 8KB
EEPROM 4KB

Clock Speed 16MHz

Clock Speed 16MHz



http://arduino.cc/en/Tutorial/HomePage

3 Precautions

Read this manual before attempting to use the WiFi & BLE PLC and follow its descriptions for
reference during operation.

3.1 Arduino Board

The MDUINO PLC ARDUINO ETHERNET & WIFI & BLE 21 I/0s ANALOG/DIGITAL PLUS includes
an Arduino Mega Board as controller and a ESP32 Dev programmable chip as a Wi-Fi & BLE
gateway.

3.2 Intended Audience

This manual is intended for technicians, which must have knowledge on electrical systems.

3.3 General Precautions

The user must operate M-Duino according to the performance specifications described in this
manual.

Before using the MDUINO PLC ARDUINO ETHERNET & WIFI & BLE 21 1/Os ANALOG / DIGITAL
PLUS under different conditions from what has been specified in this manual or integrating
into nuclear control systems, railroad systems, aviation systems, vehicles, combustion systems,
medical equipment, amusement machines, safety equipment and other systems, machines,
and equipment that may have a serious influence on lives and property if used improperly,
consult your INDUSTRIAL SHIELDS representative. Ensure that the rating and performance
characteristics of the Ethernet/WiFi/BLE Controller are sufficient for the systems, machines,
and equipment, and be sure to provide the systems, machines, and equipment double safety
mechanisms. This manual provides information for programming and operating the MDUINO
PLC ARDUINO ETHERNET & WIFI & BLE 21 1/0s ANALOG / DIGITAL PLUS.

4 Software interface

Industrial Shields PLC are programmed using Arduino IDE, which is a software based on the C
language. They can also be programmed using directly C but it is much easier working with
Arduino IDE as it provides lots of libraries that helps in the programming.

Industrial Shields provides boards for programming the PLCs much easier. Basically it is no
needed to define the pins and if that pins are inputs or outputs. Everything is set up
automatically if using the boards.

In order to install Industrial Shields boards, these are the steps that must be followed.
Requirements:

Arduino IDE 1.8.0 or above (better to have always the latest version).



Steps:

1. Open Arduino IDE and go to: “File -> Preferences” located in the top left corner.
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2. In Additional Boards Manager URLs write the following:

http://apps.industrialshields.com/main/arduino/boards/package industrialshields index.json

3. Press OK to save the changes.

4. Goto: Tools -> Board: ... -> Boards Manager
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http://apps.industrialshields.com/main/arduino/boards/package_industrialshields_index.json

5. Search for “industrialshields” on the browser.

& Boards Manager

y Tope [all | | industrialshields

industrialshields

Boards induded in this package:
ARDBCH Farraly, M-Duinc family.
2oling halg

Maora infa

1.18 = In=1a)
Clese
6. Click install (selecting the latest version).
Following these steps you will be able to see now the Industrial Shields Boards:
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Once it is selected the Ardbox Family or M-Duino family an extra option will appear on Tools:
There, it can be selected the exact model for every family.

& Blink | Arduino 1.8.0
File Edit Sketch Tools Help

Auto Form at Cirl+T
Archive Sketch

Fix Encoding & Reload

Serial Monitor Ctrl+Shift+M
Serial Plotter Cirl+Shift+L

WiFi1101 Firmware Updater

Board: "M-Duino family" >

Industrial Shields: "M-Duino 19R+" 3 M-Duino 19R

Port e M-Duino 19R+

Get Board Info M-Duino 21

i M-Duino 21+

Programmer: "Arduino Gemma" .
M-Duino 38AR +

Burn Bootloader .
M-Duino 38R
M-Duino 38R+
M-Duino 42
M-Duino 42+

M-Duino 50RRA +
M-Duino 53ARR+
M-Duino 54ARA+
M-Duino 57 AAR+
M-Duino 57R
M-Duino 57R+
M-Duino 58
M-Duino 58+

Also there are some examples of programming in File -> Examples -> M-Duino Family.
Furthermore there are some extra libraries that can be found in Industrial Shields github.

https://github.com/IndustrialShields/



https://github.com/IndustrialShields/

5 How to connect PLC Arduino to PC

Connect USB port from PLC to PC.

NOTE: -
M-Duino Family uses USB-B cable.

Open Arduino IDE interface:

Select Industrial Shields boards -> M-Duino Family

Select the correct M-Duino Board:
M-Duino 21+

N vom -
L L L

- Select correct port.

TR L | —




6 How to connect PLC to power supply

- M-Duino Family PLCs are 12-24Vdc supplied. IMPORTANT: The polarity IS NOT
REVERSAL!

- Make sure that the live and GND connector of the power supply match the PLC.

- Make sure that the power supply mains output is not higher than 24Vdc.

':)WEP- Sup PI:I
GBoo |

I—* abvee |

et |

- Suggested power suppliers

il
l"H

* Not recommended for industrial applications. The e
Jack connector needs to be removed and use the live

and GND connectors. s :‘
L



7 M-duino Family Pinout

71 A Zone connection

Base
(common unit)
A Zone
5 £
=t o
28| ¢ §
= 5 °
o< S c
i O 2 =
=0 < [
SCL 21 12C/SS
SDA 20 12C/SS
RX0 1 RXO0/SS
TXO0 0 TX0/SS
RX1 19 DON'T USE
TX1 18 DON'T USE
> 16 RX2(serial 2)
RX 17 TX2(serial 2)
Z- - RS485
Y+ - RS485
B- - RS485
A+ - RS485
PIN3 3 Arduino Pin
50 SO 50 SPI
51 SI 51 SPI
52 SCK 52 SPI
Reset | Reset SPI
Vin5 Vin5 5V
PIN2 2 Arduino Pin
GND - Gnd
GND - Gnd
24Vdc Power Supply

—_—

Configuration Switch* (see section 8 for
configuring the communications.
Enabling communications disables some
1/0s)

Communication Pins (Serial 1 is used by
the ESP32 Wi-Fi & BLE integrated
module)

Power supply connectors
(24vdc — GND)

SS: Chip Select pins. These pins can act as TTL, so they can work for the Chip Select pin of any device.

Base
(common unit)
A Zone
5 £
o
o =
£8 o S
S C 5 S
25| 3 =
=0 < o
AREF AREF  |Arduino PIN
IOREF2 | IOREF2 [Arduino PIN
IOREF1 | IOREF1 [Arduino PIN
7Vdc 7Vdc -
GND GND GND
3.3vdc | 3.3vdc |Arduino PIN
GND GND GND
5vdc 5Vdc -
GND GND GND

DS3(SD)
FO rgass HD




o : W

i d <§ S\ D =f

- & [ 4

< : :;

f! HIC Battwry |/ 16;:8 . i
Ethernet Arduino Power
Connector Reset button
USB programmer Autoreset

connector

*NOTE: Autoreset. Arduino mega has auto reset when using serial communication code. Set switch to OFF when using
serial communication. When uploading code to Arduino Mega set switch to ON.



7.2 B Zone (Analog Shield)
[
- 1
B Zone
—_ c
o8 a -
S o o c Analog
8 8 = g 0-10vie
£ | 3 2 o
8 k- 5 24V
Dugtat
10.12 59 Analog/ Digital In q:'l'v'o
10.11 58 Analog/ Digital In
10.10 57 Analog/ Digital In
10.9 56 Analog/ Digital In
10.8 55 Analog/ Digital In
10.7 54 Analog/ Digital In
(1)10.6/INT1 - GND 10.6
10.6/INT1t 3 Interrupt 1 In o AT 34}
(-)10.5/INTO - GND 10.5 10,69 1ol
10.5/INTO* 2 Interrupt O In dpiailhgy
(0.4 - GND 10.4 05951044
10.4 26 Digital Input 310 4y
(-)10.3 - GND 10.3 04
10.3 25 Digital Input ;_5.:»:: g
()10.2 - GND 10.2 310 2t
10.2 24 Digital Input 02 <
()10.1 - GND 10.1 e01—4
10.1 23 Digital Input €10 O—i—
()10.0 = GND 10.0 00 oal
10.0 22 Digital Input
1
¢
1 = | |
Led indicator I/Os state —
B Zone
e5 c
=g | ¢ 5
Qc o 3]
s S 35 5
o = L
<
GND GND GND
AO0.7% 6 Analog Out
A0.61 5 Analog Out B
AO0.5¢ 4 Analog Out é
Q/Vdc - External Isolated Out Vdc -1
COM(-) - External Isolated Out GND T
Q0.71 6 Digital/PWM Out 8
Q0.6 5 Digital/PWM Out g
Q0.5! 4 Digital/PWM Out 5ud
Q0.4 40 Digital Out gEE2
Q0.3 39 Digital Out c2k
Q0.2 38 Digital Out 2%
Q0.1 37 Digital Out R =
Q0. 36 Digital Out

Analog/Digital Inputs

Interrupt Inputs (isolated)

Digital Inputs (isolated)

Configuration Switch*
(see section 8 to select the correct
configuration for outputs).

Analog Outputs

Voltage Supply/Reference for
Digital/PWM Outputs (isolated)

PWM/Digital Outputs

1 See section 8 to select suitable switch configuration for enable these connections.



8 Switch Configuration

8.1 A Zone: Communications

LEFT ZONE
Switch Analog Shield
ON | OFF
B ZONE
Pin 3/10.6 10.6 Pin3
Pin 2/10.5 10.5 Pin 2
uSD & RS-485
D53(SD) - SD
FD RS-485 HD HD FD

*Although the Serigraphy of the
Switches will only reference to the

’OFF - QN
SCL/12.8
SDA /12.5
Rx1/11.6

y 2\ Tx1/11.5
| ' ~ Pin3/10.86
o

Pin2/10.5
D53(SD)

Analog Shields,

4. SCL/12.6: ALWAYS AT OFF POSITION. On the MDUINO PLC ARDUINO ETHERNET & WIFI &
BLE 21 1/0s ANALOG/DIGITAL PLUS Controller this switch is not connected.

3. SDA/12.5: ALWAYS AT OFF POSITION. On the MDUINO PLC ARDUINO ETHERNET & WIFI &
BLE 21 1/0Os ANALOG/DIGITAL PLUS Controller this switch is not connected.

2. RX1/11.6: ALWAYS AT OFF POSITION. On the MDUINO PLC ARDUINO ETHERNET & WIFI &
BLE 21 1/0Os ANALOG/DIGITAL PLUS Controller this switch is not connected.

1. TX1/11.5: ALWAYS AT OFF POSITION. On the MDUINO PLC ARDUINO ETHERNET & WIFI &
BLE 21 1/0s ANALOG/DIGITAL PLUS Controller this switch is not connected.



4. Pin 3/10.1: Choosing between Pin 3 or the input 10.6. If this switch is ON, it enables the 10.6
input and disables the Pin 3. If this switch is OFF, it enables Pin 3 and disables 10.6.

3. Pin 2/10.0: Choosing between Pin 2 or the input 10.5. If this switch is ON, it enables the 10.5
input and disables the Pin 2. If this switch is OFF, it enables Pin 3 and disables 10.5.

2. D53(SD): ALWAYS AT OFF POSITION. On a MDUINO PLC ARDUINO ETHERNET & WIFI &
BLE 21 1/0s ANALOG/DIGITAL PLUS Controller this switch is not connected. It allows the uSD
storage.

1. FD RS-485 HD: Choosing between FD or HF. If this switch is ON, it enables the Half Duplex
(HD) option and disables the FD. If this switch is OFF, it enables Full Duplex (FD) and disables
HD.

LEFT ZONE
SWITCH ON OFF
NC - -
NC - -
RTC SCL RTC -
RTC SDA RTC -

1. RTC SDA: This switch enables the communication to communicate with the RTC
using 12C. Having this switch in ON mode it actives this communication,
whereas if it is in OFF mode it disables the 12C to reach the RTC.

2. RTC SCL: This switch enables the communication to communicate with the RTC
using 12C. Having this switch in ON mode it actives this communication,
whereas if it is in OFF mode it disables the 12C to reach the RTC.

3. NC: Not connected. This switch is not connected to anything, it doesn’t matter
if it is in ON mode or OFF mode.

4. NC: Not connected. This switch is not connected to anything, it doesn’t matter
if it isin ON mode or OFF mode.



8.2 B Zone: Analog Shield

B ZONE
SWITCH ON | OFF
NC - -
Q0.7 Q0.7 | AO.7
Q0.6 Q0.6 | AO.6
Q0.5 Q0.5 | A0.5

28I NC

23000
£%5|Qos

For the Analog Shield if a switch is set to ON, it can only act as Digital Output. If it is set to OFF
it can only act as an Analog Output.

If it is desired to use a Digital Output the pin must be set to ON and the pin that will provide
this digital output is represented with Q0.X, being X any number of the tables above.

If it is desired to use an Analog Output the pin must be set to OFF and the pin that will provide
this analog output is represented with A0.X, being X any number of the tables above.

9 1/0s 5V pins

The MDUINO PLC ARDUINO ETHERNET & WIFI & BLE 21 1/0s ANALOG/DIGITAL PLUS has some
of the Mega board pins available. These pins can be programmed according to Arduino
features such as I/Os operating at 5V or any additional features present in the pins (for
example I12C communication in pins SCL and SDA). As this pins are directly connected to the
Arduino Mega board they are not as well protect as the normal inputs. These pins are mainly
meant to be used as prototyping.

The Arduino board available pins are summarized in the table below. In order to access some
of these pins the configuration switch must be set to OFF position (see section 8) and some
extra considerations must be taken in consideration when using these pins.

M-Duino terminal Arduino pin Enable Arduino pin
SCL 21 Communication switch: OFF
SDA 20 Communication switch OFF
RX0 0
TX0 1
RX1 19 DON'T USE!

TX1 18 DON'T USE!

MISO 50

MOSI 51

SCK 52

Pin 3 3 Communication switch: OFF
Pin 2 2 Communication switch: OFF




*IMPORTANT: Do not connect the terminals in the chart above to voltages higher than 5V.
These terminals provide direct access to the Mega board.

A part from the switch configuration there are some special conditions depending on these 5V.
Now it is going to be shown the considerations to operate with these pins.

9.1 12C pins - SDA/SCL

The 12C protocol is meant to work in a pull-up configuration. A pull-up configuration means
that when the pin is at rest (nothing connected to it) it always reads a HIGH value. In this case
it reads 5V when nothing is connected. The pull-up configuration is stablished by default in
these pins.

If it is meant to work them as a GPIO at 5V, it has to be considered that they are pull-up
inputs.

*IMPORTANT: 12.5 & 12.6 are not pull-up inputs although they are referred to the I12C pins
(switch configuration). There is a “reverse pull-up circuit “that is stablished in order to have the
same behaviour as the other inputs.

9.2  Serial 0 - RX0/TX0

The Serial0 protocol can work also as a 5V pin. These pins should be used ultimately, only in
case that all the 5V pins are already performing a function. This is because they are shared
with the USB interface. If using these pins, the USB communication cannot be working at the
same time. When the PLC is not installed, the USB communication is normally required for
debugging, uploading and intercommunicating with the Ethernet controller. If using both
interfaces at the same time the Arduino board will get blocked.

These pins are not stablished with a pull-up or a pull-down configuration. The state of these
pins is unknown. If these pins must be used, they require a pull-up or a pull-down
configuration. The Arduino board allows the pins to be set in a pull-up configuration. If not it
must be stablished an external pull-up or pull-down circuit in order to correctly work with
these pins.

9.3  Serial 1 - RX1/TX1

In the WiFi & BLE Controller, Serial 1 is used to communicate through the ESP32 integrated in
the MDUINO PLC ARDUINO ETHERNET & WIFI & BLE 21 I/Os ANALOG/DIGITAL PLUS.

DON’'T USE SERIAL 1



94  SPI-MISO/MOSI/SCK

These pins can only work as a 5V pins if the Ethernet protocol is not going to be used. As the
Ethernet protocol uses the SPI to communicate with the Arduino board, both behaviours
cannot happen at the same time as the Ethernet would not work.

These pins are not stablished with a pull-up or a pull-down configuration. The state of these
pins is unknown. If these pins must be used, they require a pull-up or a pull-down
configuration. The Arduino board allows the pins to be set in a pull-up configuration. If not it
must be stablished an external pull-up or pull-down circuit in order to correctly work with
these pins.

9.5 Pin2/Pin3

These pins are only referred to the inputs 10.5/10.6. If the switch configuration is in OFF
position the pins Pin 2/Pin 3 will be available.

These pins are not stablished with a pull-up or a pull-down configuration. The state of these
pins is unknown. If these pins must be used, they require a pull-up or a pull-down
configuration. The Arduino board allows the pins to be set in a pull-up configuration. If not it
must be stablished an external pull-up or pull-down circuit in order to correctly work with
these pins.



10 A Zone Features: Communications & RTC & uSD

10.1 RS-232

The Arduino Mega function code to access the RS-232 port in the M-Duino is Serial2 (pins 16
and 17 of the Arduino Mega).

For the RS-232 communication protocol there isn’t any switch that affects it. So it does not
matter the configuration of the switches to implement a RS-232 communication.

Using the boards of Industrial Shields, there is a library that simplifies the RS-232
implementation.

10.2 RS-485

For RS485 communication protocol the defined Arduino Mega pins are showed in the chart
below.

Function Arduino Pin

DI 14

RO 15

RE 11

DE 46

For the RS-485 communication protocol there is only one switch that affects in this
communication. The RS-485 protocol will be always enabled, the only switch that affects is the
one called “FD rs-485 HD” (See Section 8). This switch makes the choosing between RS-485
Half Duplex or RS-485 Full Duplex (RS-422).

Using the boards of Industrial Shields, there is a library that simplifies the RS-485
implementation.

10.3 12C

12C communication DOES NOT REQUIRE a pull-up resistor for the M-Duino Family. The pull-up
resistor is already implemented in the PCB.

12C communication is configured by switches, so the switches must be configured in order to
enable the 12C communication.



To enable 12C the switches SCL/12.6(12.1) & SDA/12.5(12.0) must be set to OFF mode. In this
mode the inputs are totally disabled and the 12C is now enabled.

Industrial Shields does not provide any library to implement the 12C as it can be used the
standard library of Arduino called Wire.

10,4 SPI

The M-Duino pins used for the SPI bus are summarized in the table below. For SPI bus MISO,
MOSI and CLOCK pins are common to all the connected devices to the M-Duino, conversely,
each of the connected devices will have a single and dedicated SS pin.

Function M-Duino connection Mega board pin
MISO 50 S0 50
MOSI 518l 51
CLOCK 52 SCK 52
Reset Reset Reset
SS SCL/SDA/RX0/TX0/RX1/TX1/RX3/TX3/Pin2/Pin3 | 21/20/1/0/19/18/15/14/2/3

Check the switch configuration at section 8 to enable SS pins.

10.5 TTL

M-Duino has one TTL port, RX0/TX0 (RX1/TX1 is used for Wi-Fi and BLE communication). TTLO
is accessed with the function Serial (pins 0 and 1 of the Arduino Mega).

10.6 Ethernet

M-Duino Ethernet port controller is based on w5500 IC, which is the compatible IC compatible
with Arduino Ethernet2 Shield libraries. All Ethernet shield Arduino libraries are compatible
with the M-Duino. In the M-Duino, W5500 IC communicates to the Mega board via SPI bus (SS
Arduino Mega pin 10).

10.7 RTC

M-Duino RTC Module is based on the DS1307 Chip. This chip works with the 12C protocol
communication, so it is required to have enabled the I12C protocol.

4 switches have to be configured in order to enable the RTC features:

LEFT ZONE
SWITCH ON OFF
NC - -




NC

RTC SCL

RTC

RTC SDA

RTC

RTC SCL & RTC SDA must be set to ON mode to
enable the I12C wires to the RTC. If they are in OFF

mode, the Arduino won’t communicate with the RTC.

Switch Analog Shield
ON OFF I2C must be enabled in order to communicate with
SCL/I2.6 2.6 SCL the RTC. See section 11 12C to enable it.
SDA/I2.5 12.5 SDA

Using the boards of Industrial Shields, there is a library that simplifies the RTC implementation
called RTC.

10.8 uSD

The micro SD uses the SPI communication to interact with the Arduino Mega. The SPI protocol
is always enabled, as there are no switches that configure it. However, there is a switch that
must be placed to ON mode in order to communicate with the uSD:

D53(SD): If this Switch is OFF, it enables the Chip Select of the microSD socket and disables
Q2.0. If this switch is ON, it enables the Q2.0 output. If the switch is in ON mode the microSD
can’t be used.

The uSD socket is found in the TOP part of the communication Shields, so in the frontal part of
the PLC, it is required to open the plastic found in the frontal part and the socket is located
under the supply of the Arduino.

Switch Analog Shield
ON OFF
D53(SD) Q2.0 D53(SD)

Using the boards of Industrial Shields, there is a library that simplifies the uSD implementation
called SD. It is the same as the Arduino library, with the only modification of using the pin 53 to
select the Chip Select of the uSD chip.



10.9 WiFi & BLE

The WiFi and Bluetooth integrated module consists in a single 2.4 GHz Wi-Fi and Bluetooth
combo chip designed with the TSMC ultra-low-power 40 nm technology. It is designed to achieve
the best power and RF performance, showing robustness, versatility and reliability in a wide
variety of applications and power scenarios. Some applications are Generic Low-power loT
Sensor Hub, Generic Low-power loT Data Loggers and Mesh Network.

It is designed for Internet-of-Things (loT) applications.

10.9.1 General Specifications:

Wi-Fi

e 802.11b/g/n

e 802.11 n (2.4 GHz), up to 150 Mbps
Bluetooth

e Bluetooth 4.2 BR/EDR BLE dual mode controller
e +12 dBm transmitting power
e NZIF receiver with -97 dBm BLE sensitivity

10.9.2 WiFi & Bluetooth Module Configuration

In order to configure the WiFi & BLE module, you must connect it to a PC.
To connect it you will need a micro USB to USB cable.

The slot for the micro USB input is located on the right side of your equipment.

To load the program into the ESP32 you have to install the board on the Arduino IDE software.
Go to File > Preferences and into Additional Boards Manager URLs add the next

URL: https://dl.espressif.com/dl/package esp32 index.json

*|f you already have one URL put it next to the other separeted by coma, like in the image
below.


https://dl.espressif.com/dl/package_esp32_index.json

Preferences

X

Settngs  Network

Sketchbook location:

C:\Users WSER Documents \Arduing Growse
Editor language: English (Englsh) v | (requres restart of Arduino)

Editoe font s7e: 13

Interface scale: MAstomatic 100 2 % (requires restart of Arduino)

Thems: Defaut theme «  (requires restart of Arduino)

Show verbose output during: [] compilation [ upload

Compier warnings: Nore

] Dispiay ine numbers

[ Enabde Code Folding

[ verify code after upload

[T Us= external editor

£ Agressively cache complied core

£ Check for updates on startup

4 Undate sketch fiies to new extension on save (.pde -> .no)

[ Save when verifying or uploadng
Additonal Boards Manager URLs: oMa&»aMdes_pdu.jsm, https:/ fdi. espresst. com /d package_esp32_ndex.js0 =)

C:\Users USER \AppData Local\Arduino 15 preferences. txt

fore preferences can be edited drecly in the fie
riy when Ardurs & not ruving

2Ot o

Now you are able to install the board. Go to Tools > Boards > Boards Manager and search by
ESP32.

Will appear the esp32 by Espressif Systems. Install it.

Once it is installed go to Tools > Boards and choose ESP32 Dev Module



D skerch_may17a | Arduino 180
fie Ecit Sketch Tools Help

Auto Form at CulsT
Archeve Skeuch
shetch_rmay! 7 Fix Encoding & Retoad
: A Senal Monstor Cut+Shtt+M
Y senal Plotter Cut+Shittel

Wil 101 Fsrmware Updater

‘Board: €932 Doy Modkile” 3 4
Flash Made: “QI0" p LilyPad Archaino
i loop( Flash Fr ¥ “80MHz* J Archano Pro or Pro Mani
PUE W emmife -+ 290MHz (WIFI/BT)" ) Astuno NG or older
Flash Size: "4MB (32Mb)° 5 Arduno Robot Control
| PSRAM: “Disablled”  ArcuinoRabot Mokor
Partition Schem e "Default AMB with spitfs (128 APP/1.5MB SPIFFS)* g Ao Gemma
Upload Speed "921600 3 Adafrut Ciromt Payground
Corte Debug Leved: "None” Archino Yan i
ot Arduino industrial 101
Get Board to Linino One
Archano Uro Wik
Programmer: “Arduno Gemma® X E$922 Arcuing
Burn Bootoader % ESP32 Dev Module
ESP32 Wrover Module
ESP32 Pica Kit
Turta loT Node
TTGO LoRa32-OLED V1
XinaBox CW02
SparkFun ESP32 Thing
u-blow NIMA-W10 senes (ESP32)
Widora AIR

Electronic SweetPeas - ESP320

The internal connections between the ESP32 module and the Arduino Mega are the following:

Arduino Mega Pinout ESP32 Pinout
5Vdc Vce
GND GND
Tx1 (Pin 18) TxD
Rx1 (Pinl19) RxD

WiFi and Bluetooth are always enabled as there are no switches that configure it.

The WiFi and Bluetooth module uses Seriall for communication.



11 I/0 technical details:

Digital Output Waveform:

DIGITALOUT

DIGITAL OUT

PWM OUTPOUT




Analog Out Turn On:

]

ANALOGOUT

ANALDG OUT
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13 Connector details:

The connector inside the PLCs that mounts on the PCB is MC 0,5/10-G-2,5 THT — 1963502
from Phoenix contact. MCO0,5/10-G-2,5THT

For 1/0 and power supply there is a FK-MC 0,5/10-ST-2,5 - 1881406 connector from Phoenix
contact. FK-MC 0,5/10-ST-2,5

Connection details:

Article reference | MC 0,5/10-G-2,5 THT
Height 8,1mm
Pitch 2,5mm
Dimension 22,5mm
Pin dimensions 0,8x0,8mm
Pin spacing 2,50mm
Article reference FK-MC 0,5/10-ST-2,5
Rigid conduit section min. 0,14 mm?
Rigid conduit section max. 0,5 mm?
Flexible conduit section min. 0,14 mm?
Flexible conduit section max. 0,5 mm?
Conduit section AWG/kcmil min. 26
Conduit section AWG/kcmil max. 20



https://www.phoenixcontact.com/online/portal/us?uri=pxc-oc-itemdetail:pid=1963502&library=usen&tab=1
https://www.phoenixcontact.com/online/portal/us?uri=pxc-oc-itemdetail:pid=1881406&library=usen&tab=1#General

Dimension :

129

DIN Rail mounting

14 Mechanical Characteristics
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About Industrial Shields:

Direction: Fabrica del Pont, 1-11

Zip/Postal Code: 08272

City: Sant Fruitds de Bages (Barcelona)

Country: Spain

Telephone: (+34) 938 760 191 / (+34) 635 693 611

Mail: industrialshields@industrialshields.com
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